{"id":"CVE-2016-4003","published":"2016-04-12T16:00:00Z","modified":"2024-08-06T00:17:29Z","title":"Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x…","vendor":null,"product":null,"tier":"tail","description":{"text":"Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x before 2.3.28, when using a single byte page encoding, allows remote attackers to inject arbitrary web script or HTML via multi-byte characters in a url-encoded parameter.","provenance":"source","from":"CVE.org"},"cvss":null,"epss":{"score":0.11562,"percentile":0.96002,"provenance":"source"},"cwes":[],"references":[{"url":"http://struts.apache.org/docs/s2-028.html","tags":["x_refsource_CONFIRM"]},{"url":"http://www.securityfocus.com/bid/86311","tags":["vdb-entry","x_refsource_BID"]},{"url":"http://www.securitytracker.com/id/1035268","tags":["vdb-entry","x_refsource_SECTRACK"]},{"url":"https://issues.apache.org/jira/browse/WW-4507","tags":["x_refsource_CONFIRM"]}],"priority":{"score":19.2,"factors":[{"name":"EPSS percentile","points":19.2}]},"affected":[{"ecosystem":"Maven","package":"org.apache.struts:struts2-core","vulnerableRanges":[">=2.0.0, <2.3.28"],"patched":["2.3.28"],"from":["GHSA-m3x6-9v6h-4g28"],"provenance":"source"}],"euvd":{"id":"EUVD-2022-4483","exploited":false,"provenance":"source"}}