Patchfirst
CVE-2007-0450 Public exploit EPSS 91.2%

Directory traversal vulnerability in Apache HTTP Server and Tomcat 5.x before 5.5.22 and 6.x before 6.0.10, when using…

Summary

The flaw is a directory traversal vulnerability in Apache HTTP Server and Tomcat (5.x before 5.5.22 and 6.x before 6.0.10) when certain proxy modules, namely mod_proxy, mod_rewrite, and mod_jk, are in use, where dot-dot sequences combined with forward slashes, backslashes, or URL-encoded backslashes (%5C) are interpreted differently by Tomcat than by Apache.

Official description · CVE.org

Directory traversal vulnerability in Apache HTTP Server and Tomcat 5.x before 5.5.22 and 6.x before 6.0.10, when using certain proxy modules (mod_proxy, mod_rewrite, mod_jk), allows remote attackers to read arbitrary files via a .. (dot dot) sequence with combinations of (1) "/" (slash), (2) "\" (backslash), and (3) URL-encoded backslash (%5C) characters in the URL, which are valid separators in Tomcat but not in Apache.

Breakdown
25.0 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Exploit-DB) was available 2 days before disclosure.

  1. Public exploit codeExploit-DB2 days before
  2. Disclosedday 0

2 related vulnerabilities in the same code over 2 months. The latest fix listed for tomcat is 6.0.16.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2007-0450Directory traversal vulnerability in Apache HTTP Server and…16 Mar 2007
  2. relatedLow

    Why these are linked:

    • Stated in the CVE text…er before passing the URL to Tomcat, which allows remote attackers to access protected pages via a crafted prefix JkMount, possibly involving double-encoded .. (dot dot) sequences and directory traversal, a related issue to CVE-2007-0450.
    CVE-2007-1860mod_jk in Apache Tomcat JK Web Server Connector 1.2.x before…25 May 2007

Fixes in tomcatMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 5.5.17CVE-2006-383525 Jul 2006
  2. 5.5.18CVE-2006-71959 May 2007
  3. 5.5.21CVE-2008-430826 Feb 2009
  4. 6.0.10CVE-2007-045016 Mar 2007
  5. 6.0.14CVE-2007-245014 Jun 2007
  6. 6.0.15CVE-2007-533312 Feb 2008
  7. 6.0.16CVE-2008-000212 Feb 2008Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.tomcat:tomcat.

Mavenorg.apache.tomcat:tomcatGHSA-4prh-gqw8-rgh5

Upgrade to 6.0.35 or later

Fixes this CVE and 8 other known vulnerabilities in this package (CVE-2007-2449, CVE-2007-5333, +6).

Set the version to 6.0.35 or later in your pom.xml or build.gradle.

First fixed in 6.0.10 for CVE-2007-0450.

Affected versions, by release line

If you runUpgrade to
6.0 up to 6.0.106.0.35first fix for this CVE: 6.0.10
5.0 up to 5.5.225.5.35first fix for this CVE: 5.5.22

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

56 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close