Patchfirst
CVE-2012-0392 Public exploit EPSS 97.5%

The CookieInterceptor component in Apache Struts before 2.3.1.1 does not use the parameter-name whitelist, which…

Summary

The CookieInterceptor component in Apache Struts before 2.3.1.1 lacks the parameter-name whitelist that should restrict which parameters it processes.

Official description · CVE.org

The CookieInterceptor component in Apache Struts before 2.3.1.1 does not use the parameter-name whitelist, which allows remote attackers to execute arbitrary commands via a crafted HTTP Cookie header that triggers Java code execution through a static method.

Breakdown
25.0 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Exploit-DB) was available 2 days before disclosure.

  1. Public exploit codeExploit-DB2 days before
  2. Disclosedday 0

7 fixes in struts2-core over 9 years. The latest fix listed for struts2-core is 2.3.1.2.

Fixes in struts2-coreMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 2.2.1CVE-2010-187017 Aug 2010
  2. 2.2.3CVE-2011-177213 May 2011
  3. 2.2.3.1CVE-2012-03918 Jan 2012KEV
  4. 2.2.3.1CVE-2012-03928 Jan 2012
  5. 2.2.3.1CVE-2012-08382 Mar 2012
  6. 2.3.1.1CVE-2012-03938 Jan 2012
  7. 2.3.1.2CVE-2011-39231 Nov 2019Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 1 ecosystem. Main package: org.apache.struts:struts2-core.

Mavenorg.apache.struts:struts2-coreGHSA-2ppp-xj34-vvf7

Upgrade to 2.5.33

Fixes this CVE and 23 other known vulnerabilities in this package (CVE-2008-6505, CVE-2010-1870, +21).

Still affected on this line by CVE-2024-53677 (fixed in 6.4.0, a newer line); CVE-2025-68493 (no fix published).

Set the version to 2.5.33 or later in your pom.xml or build.gradle.

First fixed in 2.2.3.1 for CVE-2012-0392.

Affected versions

If you runUpgrade to
All versions before 2.2.3.12.5.33first fix for this CVE: 2.2.3.1

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (1)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • Mavenorg.apache.struts.xwork:xwork-core
    Affected: All versions before 2.2.3.1Upgrade to 2.3.18 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

7 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close