Patchfirst
CVE-2013-2115 Public exploit EPSS 74.6%

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is…

Official description · CVE.org

Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag. NOTE: this issue is due to an incomplete fix for CVE-2013-1966.

Breakdown
24.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Metasploit) was available 47 days before disclosure.

  1. Public exploit codeMetasploit47 days before
  2. Disclosedday 0

See the family tree

A fix was bypassed or incomplete once over 4 years. The latest fix listed for struts2-core is 2.3.14.3.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2013-1965Struts Showcase App 2.0.0 through 2.3.13, as used in Struts 2…10 Jul 2013
  2. same family
    CVE-2013-1966Struts 2 before 2.3.14.2 allows remote attackers to execute…10 Jul 2013
  3. incomplete fixHigh

    Why these are linked:

    • Stated in the CVE textNOTE: this issue is due to an incomplete fix for CVE-2013-1966.
    • Similar weakness in the same product (machine-matched)same package + description similarity
    This CVECVE-2013-2115Struts 2 before 2.3.14.2 allows remote attackers to execute…10 Jul 2013
  4. same family
    CVE-2017-9787When using a Spring AOP functionality to secure Struts actions…13 Jul 2017

Fixes in struts2-coreMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 2.3.1.2CVE-2011-39231 Nov 2019
  2. 2.3.4.1CVE-2012-43865 Sep 2012
  3. 2.3.14.2CVE-2013-196610 Jul 2013
  4. 2.3.14.2CVE-2013-211510 Jul 2013
  5. 2.3.14.3CVE-2013-196510 Jul 2013
  6. 2.3.14.3CVE-2013-213416 Jul 2013
  7. 2.3.14.3CVE-2013-213516 Jul 2013Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 1 ecosystem. Main package: org.apache.struts:struts2-core.

Mavenorg.apache.struts:struts2-coreGHSA-7ghm-rpc7-p7g5

Upgrade to 2.5.33

Fixes this CVE and 23 other known vulnerabilities in this package (CVE-2008-6505, CVE-2010-1870, +21).

Still affected on this line by CVE-2024-53677 (fixed in 6.4.0, a newer line); CVE-2025-68493 (no fix published).

Set the version to 2.5.33 or later in your pom.xml or build.gradle.

First fixed in 2.3.14.2 for CVE-2013-2115.

Affected versions

If you runUpgrade to
2.0.0 up to 2.3.14.22.5.33first fix for this CVE: 2.3.14.2

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (1)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • Mavenorg.apache.struts.xwork:xwork-core
    Affected: 2.0.0 up to 2.3.14.2Upgrade to 2.3.18 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

4 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close