Upgrade to 4.0.2
Still affected on this line by CVE-2022-22965 (fixed in 5.2.20.RELEASE, a newer line); CVE-2024-38819 (no fix published).
Set the version to 4.0.2 or later in your pom.xml or build.gradle.
The first fix for CVE-2014-0054.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 4.0.0 up to 4.0.2 | 4.0.2 |
| All versions before 3.2.8 Still affected on this line by CVE-2022-22965 (fixed in 5.2.20.RELEASE, a newer line); CVE-2024-38819 (no fix published). | 3.2.8 |
“Up to” means the second version is the fix and is not affected.