Patchfirst
CVE-2015-9251 Public exploit EPSS 29.7%

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

Heading is the official description · CVE.org
Breakdown
61.4 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 3 years after disclosure. Public exploit code (PoC-in-GitHub) appeared 11 months after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+11 mo
  3. First seen exploitedVulnCheck KEV evidence+3 yrs

7 fixes in jquery over 7 years. The latest fix listed for jquery is 3.5.0.

Fixes in jquerynpm package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.6.3CVE-2011-49698 Mar 2013
  2. 1.9.0CVE-2012-670818 Jan 2018
  3. 1.9.0CVE-2020-765619 May 2020
  4. 3.0.0CVE-2015-925118 Jan 2018
  5. 3.0.0CVE-2016-1070718 Jan 2018
  6. 3.4.0CVE-2019-1135819 Apr 2019
  7. 3.5.0CVE-2020-1102229 Apr 2020Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

4 packages in 4 ecosystems. Main package: jquery (npm, NuGet).

npmjqueryNuGetjQueryGHSA-rmxg-73gg-4p98

Upgrade to 3.5.0 or later

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2019-11358, CVE-2020-11022, +1).

npmnpm install jquery@3.5.0
NuGetSet the version to 3.5.0 or later in your .csproj

First fixed in 3.0.0 for CVE-2015-9251.

Affected versions, by release line

If you runUpgrade to
1.12.3 up to 3.0.03.5.0first fix for this CVE: 3.0.0
All versions before 1.12.2

Still affected on this line by CVE-2019-11358 (fixed in 3.4.0, a newer line); CVE-2020-11022 (fixed in 3.5.0, a newer line); CVE-2020-11023 (fixed in 3.5.0, a newer line).

1.12.2

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (2)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • Mavenorg.webjars.npm:jquery
    Affected: 1.12.3 up to 3.0.0; All versions before 1.12.2Upgrade to 3.5.0 or later (older lines: 1.12.2)
  • RubyGemsjquery-rails
    Affected: All versions before 4.2.0Upgrade to 4.4.0 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 5 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

38 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close