Patchfirst
CVE-2016-2098 Public exploit EPSS 81.4%

Action Pack in Ruby on Rails before 3.2.22.2, 4.x before 4.1.14.2, and 4.2.x before 4.2.5.2 allows remote attackers to execute arbitrary Ruby code by leveraging an application's unrestricted use of the render method.

Summary

The flaw lies in Action Pack, the component of Ruby on Rails, in versions before 3.2.22.2, 4.x before 4.1.14.2, and 4.2.x before 4.2.5.2. An attacker with remote access can execute arbitrary Ruby code by abusing an application's unrestricted use of the render method, which requires that the affected application pass untrusted input into render.

Heading is the official description · CVE.org
Breakdown
24.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) was available 37 days before disclosure.

  1. Public exploit codePoC-in-GitHub37 days before
  2. Disclosedday 0

8 fixes in actionpack over 4 years. The latest fix listed for actionpack is 6.0.3.2.

Fixes in actionpackRubyGems package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 4.1.14.1CVE-2015-757616 Feb 2016
  2. 4.2.5.1CVE-2015-758116 Feb 2016
  3. 4.2.5.1CVE-2016-075116 Feb 2016
  4. 4.2.5.1CVE-2016-075216 Feb 2016KEV
  5. 4.2.5.2CVE-2016-20987 Apr 2016
  6. 6.0.3.1CVE-2020-816419 Jun 2020
  7. 6.0.3.1CVE-2020-81662 Jul 2020
  8. 6.0.3.2CVE-2020-81852 Jul 2020Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: actionpack.

RubyGemsactionpackGHSA-78rc-8c29-p45g

Upgrade to 4.2.5.2 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2016-0752).

Gemfilegem "actionpack", ">= 4.2.5.2"

The first fix for CVE-2016-2098.

Affected versions, by release line

If you runUpgrade to
4.2.0 up to 4.2.5.24.2.5.2
4.0.0 up to 4.1.14.24.1.14.2
3.0.0 up to 3.2.22.23.2.22.2

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

12 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close