Patchfirst
CVE-2018-12613 Public exploit EPSS 98.4%

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially…

Summary

An issue in phpMyAdmin 4.8.x before 4.8.2 lets an attacker include and potentially execute files on the server, because the code that redirects and loads pages inside phpMyAdmin improperly checks whitelisted pages. Exploitation normally requires an authenticated session, but the flaw can be reached without authentication when the configuration sets ServerDefault to 0 (bypassing the login requirement), and it can lead to arbitrary code execution when AllowArbitraryServer is enabled and the attacker controls a host they can specify.

Official description · CVE.org

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).

Breakdown
66.0 / 100
Exploited
Yes, in VulnCheck KEV
Reports
1
Tactics
0/15

First seen exploited 4 years after disclosure. Public exploit code (Metasploit) was available 2 days before disclosure.

  1. Public exploit codeMetasploit2 days before
  2. Disclosedday 0
  3. First seen exploitedVulnCheck KEV evidence+4 yrs

7 fixes in phpmyadmin/phpmyadmin over 10 months. The latest fix listed for phpmyadmin/phpmyadmin is 4.8.4.

Fixes in phpmyadmin/phpmyadminPackagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 4.7.8CVE-2018-726021 Feb 2018
  2. 4.8.0.1CVE-2018-1018819 Apr 2018
  3. 4.8.2CVE-2018-1258121 Jun 2018
  4. 4.8.2CVE-2018-1261321 Jun 2018
  5. 4.8.3CVE-2018-1560524 Aug 2018
  6. 4.8.4CVE-2018-1996811 Dec 2018
  7. 4.8.4CVE-2018-1996911 Dec 2018Latest listed

techniques

No techniques linked

No high- or medium-confidence techniques. The 1 available link are lower confidence and listed below.

Lower-confidence links (1)

These come from early or generic mappings, text matching, or contradict this CVE’s details (for example a public-facing technique on a bug that needs a user to open a file). Shown for completeness.

  • Exploit Public-Facing ApplicationT1190 machine-matched from report text

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: phpmyadmin/phpmyadmin.

Packagistphpmyadmin/phpmyadminGHSA-x394-g9j8-x7mf

Upgrade to 4.8.2 or later

Set the version to 4.8.2 or later in your composer.json.

The first fix for CVE-2018-12613.

Affected versions

If you runUpgrade to
4.8 up to 4.8.24.8.2

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Named in 1 threat report
1 reportMicrosoft

Reports are matched by finding the exact id CVE-2018-12613 in their text; nobody has reviewed the match. One passage is shown per report, at most 320 characters, linked to the original.

Also mentioned in 8 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

7 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close