Patchfirst
CVE-2018-1335 Public exploit EPSS 93.6%

From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used…

Apache Software Foundation · Apache Tika

Summary

Apache Tika's tika-server component, in versions 1.7 through 1.17 of Apache Tika, fails to properly handle specially crafted client-supplied headers, which can be used to inject commands into the server's command line. An attacker can exploit this when tika-server is reachable by untrusted clients, since the flaw only affects deployments exposed to such clients.

Official description · CVE.org

From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to inject commands into the command line of the server running tika-server. This vulnerability only affects those running tika-server on a server that is open to untrusted clients. The mitigation is to upgrade to Tika 1.18.

Breakdown
61.1 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 6 years after disclosure. Public exploit code (Metasploit) was available the same day.

  1. DisclosedPublic exploit codeMetasploitday 0
  2. First seen exploitedVulnCheck KEV evidence+6 yrs

6 fixes in tika-core over 17 months. The latest fix listed for tika-core is 1.19.

Fixes in tika-coreMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.13CVE-2016-443429 Sep 2017
  2. 1.14CVE-2016-68096 Apr 2017
  3. 1.18CVE-2018-133525 Apr 2018
  4. 1.18CVE-2018-133825 Apr 2018
  5. 1.19CVE-2018-1176219 Sep 2018
  6. 1.19CVE-2018-801719 Sep 2018Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.tika:tika-core.

Mavenorg.apache.tika:tika-coreGHSA-9r24-gp44-h3pm

Upgrade to 1.18

Still affected on this line by CVE-2025-66516 (fixed in 3.2.2, a newer line).

Set the version to 1.18 or later in your pom.xml or build.gradle.

The first fix for CVE-2018-1335.

Affected versions

If you runUpgrade to
1.7 up to 1.181.18

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 2 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

5 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close