Patchfirst
CVE-2018-15801 Low · 3.3 EPSS 0.7%

Authorization Bypass During JWT Issuer Validation with spring-security

Spring by Pivotal · Spring Security

Official description · CVE.org

Spring Security versions 5.1.x prior to 5.1.2 contain an authorization bypass vulnerability during JWT issuer validation. In order to be impacted, the same private key for an honest issuer and a malicious user must be used when signing JWTs. In that case, a malicious user could fashion signed JWTs with the malicious issuer URL that may be granted for the honest issuer.

Breakdown
12.6 / 100
Exploited
Not confirmed
Reports
0
Tactics
1/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. What can follow

Disclosed on 19 Dec 2018. No public exploit code or confirmed exploitation is recorded.

7 fixes in spring-security-core over 2 years. The latest fix listed for spring-security-core is 5.3.2.

Fixes in spring-security-coreMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 4.2.13CVE-2019-1127226 Jun 2019
  2. 5.0.0.M2CVE-2017-499527 Nov 2017
  3. 5.0.1CVE-2018-119916 Mar 2018
  4. 5.1.2CVE-2018-1580119 Dec 2018
  5. 5.1.5CVE-2019-37959 Apr 2019
  6. 5.3.2CVE-2020-540713 May 2020
  7. 5.3.2CVE-2020-540814 May 2020Latest listed

techniques

1 , grouped by in kill-chain order 1

Lateral MovementTA0008

MITRE CTID mapping of the CVE · follow-on activity

Detection

0 rules for this CVE · 4 general rules for its techniques

Rules for this CVE

0 that reference CVE-2018-15801 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

General rules for this CVE’s techniques

These detect the technique in general, not this specific vulnerability.

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 1 ecosystem. No single main package: each of these ships the affected code.

  • Mavenorg.springframework.security:spring-security-core
    Affected: 5.1.0 up to 5.1.2Upgrade to 5.1.2 or later
  • Mavenorg.springframework.security:spring-security-oauth2-jose
    Affected: 5.1.0 up to 5.1.2Upgrade to 5.1.2 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close