Patchfirst
CVE-2018-18326 Public exploit EPSS 54.3%

DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values, resulting in lower than expected entropy. NOTE: this issue exists because of an incomplete fix for CVE-2018-15812.

Heading is the official description · CVE.org
Breakdown
24.8 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Metasploit) was available 23 months before disclosure.

  1. Public exploit codeMetasploit23 mo before
  2. Disclosedday 0

A fix was bypassed or incomplete once on the same day. The latest fix listed for DotNetNuke.Core is 9.11.0.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2018-15812DNN (aka DotNetNuke) 9.2 through 9.2.1 incorrectly converts…3 Jul 2019
  2. incomplete fixHigh

    Why these are linked:

    • Stated in the CVE textNOTE: this issue exists because of an incomplete fix for CVE-2018-15812.
    • Fixed one release later9.2.2 → 9.3.0 (DotNetNuke.Core)
    • Similar weakness in the same product (machine-matched)same package + description similarity
    This CVECVE-2018-18326DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts…3 Jul 2019

Fixes in DotNetNuke.CoreNuGet package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 9.2.2CVE-2018-158113 Jul 2019KEV
  2. 9.2.2CVE-2018-158123 Jul 2019
  3. 9.3.0CVE-2018-183253 Jul 2019KEV
  4. 9.3.0CVE-2018-183263 Jul 2019
  5. 9.4.0CVE-2019-1256226 Sep 2019
  6. 9.5.0CVE-2020-518724 Feb 2020
  7. 9.11.0CVE-2022-292230 Sep 2022Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: DotNetNuke.Core.

NuGetDotNetNuke.CoreGHSA-xx3h-j3cx-8qfj

Upgrade to 9.3.0 or later

Fixes this CVE and 5 other known vulnerabilities in this package (CVE-2015-2794, CVE-2017-0929, +3).

Set the version to 9.3.0 or later in your .csproj.

The first fix for CVE-2018-18326.

Affected versions

If you runUpgrade to
All versions before 9.3.09.3.0

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close