Patchfirst
CVE-2019-1003000 Public exploit EPSS 98.4%

A sandbox bypass vulnerability exists in Script Security Plugin 1.49 and earlier in…

Jenkins project · Script Security Plugin

Summary

The Script Security Plugin for Jenkins, version 1.49 and earlier, contains a sandbox bypass flaw in its GroovySandbox.java component. An attacker who is able to supply sandboxed scripts can use it to execute arbitrary code on the Jenkins master JVM.

Official description · CVE.org

A sandbox bypass vulnerability exists in Script Security Plugin 1.49 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java that allows attackers with the ability to provide sandboxed scripts to execute arbitrary code on the Jenkins master JVM.

Breakdown
62.1 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 12 months after disclosure. Public exploit code (PoC-in-GitHub) was available 21 months before disclosure.

  1. Public exploit codePoC-in-GitHub21 mo before
  2. Disclosedday 0
  3. First seen exploitedVulnCheck KEV evidence+12 mo

7 fixes in script-security over 13 months. The latest fix listed for script-security is 1.53.

Fixes in script-securityMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.37CVE-2017-100050525 Jan 2018
  2. 1.48CVE-2018-100086510 Dec 2018
  3. 1.48CVE-2018-100086610 Dec 2018
  4. 1.50CVE-2019-100300022 Jan 2019
  5. 1.50CVE-2019-100300122 Jan 2019
  6. 1.51CVE-2019-10030056 Feb 2019
  7. 1.53CVE-2019-100302420 Feb 2019Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.jenkins-ci.plugins:script-security.

Mavenorg.jenkins-ci.plugins:script-securityGHSA-784j-h234-m56x

Upgrade to 1.54 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2019-1003001, CVE-2019-1003029).

Set the version to 1.54 or later in your pom.xml or build.gradle.

First fixed in 1.50 for CVE-2019-1003000.

Affected versions

If you runUpgrade to
All versions before 1.501.54first fix for this CVE: 1.50

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 8 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

7 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close