Patchfirst
CVE-2019-10758 KEVPublic exploit Critical · 9.9 EPSS 84.7%

MongoDB mongo-express Remote Code Execution Vulnerability

MongoDB · mongo-express

Summary

The mongo-express web-based MongoDB administration interface, before version 0.54.0, contains a remote code execution flaw in endpoints that use the toBSON method, where the vm dependency is misused to run exec commands in a non-safe environment. An attacker with network access and low-privilege credentials, requiring no user interaction, can execute arbitrary code, with the scope changing beyond the vulnerable component.

Official description · NVD

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.

Breakdown
69.9 / 100
Exploited
Yes, in CISA KEV
Reports
0
Tactics
2/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

First seen exploited 10 months after disclosure. Public exploit code (PoC-in-GitHub) appeared 2 days after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+2 days
  3. First seen exploitedVulnCheck KEV evidence+10 mo
  4. Added to CISA KEVEU database agrees+24 mo

CISA KEV listing is when exploitation was confirmed, not necessarily the first attack.

techniques

2 , grouped by in kill-chain order, 2 cited passages 2

Initial AccessTA0001

Exploit Public-Facing Application T1190 Medium
AI mapping from the description · how it is exploited

Exploited through network-exposed web application endpoints

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints
From the official description (NVD) Original (opens in a new tab) ↗

ExecutionTA0002

Command and Scripting Interpreter T1059 Medium
AI mapping from the description · primary impact

Attacker achieves arbitrary command execution via vm

A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment
From the official description (NVD) Original (opens in a new tab) ↗

Detection

0 rules for this CVE · 244 general rules for its techniques

Rules for this CVE

0 that reference CVE-2019-10758 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: mongo-express.

npmmongo-expressGHSA-h47j-hc6x-h3qq

Upgrade to 0.54.0 or later

npmnpm install mongo-express@0.54.0

The first fix for CVE-2019-10758. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 0.54.00.54.0

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 50 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

2 links, grouped by NVD tag (1 duplicate merged)
↑ ↓ chooseEnter openEsc close