Patchfirst
CVE-2020-10684 High · 7.9 EPSS 0.3%

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively…

Red Hat · Ansible

Official description · CVE.org

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

Breakdown
46.6 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 4 years after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+4 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: ansible.

Upgrade to 2.9.7 or later

pippip install "ansible>=2.9.7"

The first fix for CVE-2020-10684. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
2.9.0 up to 2.9.62.9.6
2.9.0a1 up to 2.9.72.9.7
2.8.0 up to 2.8.92.8.9
2.8.0a1 up to 2.8.112.8.11
2.7.0 up to 2.7.172.7.17
2.7.0a1 up to 2.7.172.7.17

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 1 community threat pulse (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

6 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close