Patchfirst
CVE-2020-11082 Medium · 6.4 EPSS 1.5%

Cross-Site Scripting in Kaminari

kaminari · Kaminari

Official description · CVE.org

In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.

Breakdown
19.5 / 100
Exploited
Not confirmed
Reports
0
Tactics
3/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

  3. What can follow

Disclosed on 28 May 2020. No public exploit code or confirmed exploitation is recorded.

techniques

3 , grouped by in kill-chain order 3

ExecutionTA0002

JavaScript T1059.007
MITRE CTID mapping of the CVE · primary impact
Malicious Link T1204.001
MITRE CTID mapping of the CVE · how it is exploited

Credential AccessTA0006

Adversary-in-the-Middle T1557 also Collection
MITRE CTID mapping of the CVE · follow-on activity

Detection

0 rules for this CVE · 43 general rules for its techniques

Rules for this CVE

0 that reference CVE-2020-11082 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: kaminari.

RubyGemskaminariGHSA-r5jw-62xg-j433

Upgrade to 1.2.1 or later

Gemfilegem "kaminari", ">= 1.2.1"

The first fix for CVE-2020-11082. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 1.2.11.2.1

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

5 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close