Patchfirst
CVE-2020-16013 KEV High · 8.8 EPSS 2.8%

Google Chromium V8 Incorrect Implementation Vulnerabililty

Google · Chromium V8

Summary

The flaw is an incorrect implementation in the V8 JavaScript engine of Google Chromium, which affects Google Chrome prior to version 86.0.4240.198. A remote attacker who gets a victim to load a crafted HTML page can potentially exploit heap corruption, which requires only network access and user interaction with no prior authentication.

Official description · NVD

Inappropriate implementation in V8 in Google Chrome prior to 86.0.4240.198 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Breakdown
61.4 / 100
Exploited
Yes, in CISA KEV
Reports
0
Tactics
2/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

First seen exploited 2 months before it was disclosed.

  1. First seen exploitedVulnCheck KEV evidence2 mo before
  2. Disclosedday 0
  3. Added to CISA KEVEU database agrees+10 mo

CISA KEV listing is when exploitation was confirmed, not necessarily the first attack.

techniques

2 , grouped by in kill-chain order, 2 cited passages 2

Initial AccessTA0001

Drive-by Compromise T1189 Medium
AI mapping from the description · how it is exploited

Drive-by via malicious web page

via a crafted HTML page
From the official description (NVD) Original (opens in a new tab) ↗

ExecutionTA0002

Exploitation for Client Execution T1203 Medium
AI mapping from the description · primary impact

Exploits browser memory corruption for code execution

allowed a remote attacker to potentially exploit heap corruption
From the official description (NVD) Original (opens in a new tab) ↗

Detection

0 rules for this CVE · 38 general rules for its techniques

Rules for this CVE

0 that reference CVE-2020-16013 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

General rules for this CVE’s techniques

These detect the technique in general, not this specific vulnerability.

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

4 packages in 1 ecosystem. No single main package: each of these ships the affected code.

  • NuGetCefSharp.Common
    Affected: All versions before 86.0.241Upgrade to 86.0.241 or later
  • NuGetCefSharp.Wpf
    Affected: All versions before 86.0.241Upgrade to 86.0.241 or later
  • NuGetCefSharp.WinForms
    Affected: All versions before 86.0.241Upgrade to 86.0.241 or later
  • NuGetCefSharp.Wpf.HwndHost
    Affected: All versions before 86.0.241Upgrade to 86.0.241 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 50 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

3 links, grouped by NVD tag (2 duplicates merged)
↑ ↓ chooseEnter openEsc close