Patchfirst
CVE-2020-5241 High · 7.7 EPSS 0.6%

XSS/Script injection vulnerability in matestack

matestack · matestack-ui-core

Official description · CVE.org

matestack-ui-core (RubyGem) before 0.7.4 is vulnerable to XSS/Script injection. This vulnerability is patched in version 0.7.4.

Breakdown
15.4 / 100
Exploited
Not confirmed
Reports
0
Tactics
2/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. What they do

  2. What can follow

Disclosed on 12 Feb 2020. No public exploit code or confirmed exploitation is recorded.

techniques

2 , grouped by in kill-chain order 2

ExecutionTA0002

MITRE CTID mapping of the CVE · primary impact

CollectionTA0009

MITRE CTID mapping of the CVE · follow-on activity

Detection

0 rules for this CVE · 97 general rules for its techniques

Rules for this CVE

0 that reference CVE-2020-5241 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

General rules for this CVE’s techniques

These detect the technique in general, not this specific vulnerability.

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: matestack-ui-core.

RubyGemsmatestack-ui-coreGHSA-3jqw-vv45-mjhh

Upgrade to 0.7.4 or later

Gemfilegem "matestack-ui-core", ">= 0.7.4"

The first fix for CVE-2020-5241. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 0.7.40.7.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close