Patchfirst
CVE-2020-5267 Public exploit Medium · 4.0 EPSS 1.5%

Possible XSS vulnerability in ActionView

rails · actionview

Official description · CVE.org

In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

Breakdown
22.7 / 100
Exploited
Not confirmed
Reports
0
Tactics
2/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. What they do

  2. What can follow

Public exploit code (PoC-in-GitHub) appeared 4 days after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+4 days

7 fixes in actionview over 6 years. The latest fix listed for actionview is 7.0.2.4.

Fixes in actionviewRubyGems package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 5.0.0.1CVE-2016-63167 Sep 2016
  2. 5.2.2.1CVE-2019-541827 Mar 2019KEV
  3. 6.0.0.beta3CVE-2019-541927 Mar 2019
  4. 6.0.2.2CVE-2020-526719 Mar 2020
  5. 6.0.3.1CVE-2020-816719 Jun 2020
  6. 6.0.3.3CVE-2020-1516911 Sep 2020
  7. 7.0.2.4CVE-2022-2777726 May 2022Latest listed

techniques

2 , grouped by in kill-chain order 2

ExecutionTA0002

MITRE CTID mapping of the CVE · primary impact

CollectionTA0009

MITRE CTID mapping of the CVE · follow-on activity

Detection

0 rules for this CVE · 97 general rules for its techniques

Rules for this CVE

0 that reference CVE-2020-5267 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

General rules for this CVE’s techniques

These detect the technique in general, not this specific vulnerability.

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: actionview.

RubyGemsactionviewGHSA-65cv-r6x7-79hv

Upgrade to 6.0.2.2 or later

Gemfilegem "actionview", ">= 6.0.2.2"

The first fix for CVE-2020-5267.

Affected versions, by release line

If you runUpgrade to
6.0.0 up to 6.0.2.26.0.2.2
All versions before 5.2.4.25.2.4.2

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

6 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close