Patchfirst
CVE-2020-8264 EPSS 67.0%

In actionpack gem >= 6.0.0, a possible XSS vulnerability exists when an application is running in development mode…

Summary

The flaw is a cross-site scripting vulnerability in the Actionable Exceptions middleware of the actionpack gem, affecting versions 6.0.0 and later. It applies only when the application runs in development mode. An attacker who can get a victim to open a specially crafted URL, or to load one embedded in another page, can execute JavaScript in the context of the local application.

Official description · CVE.org

In actionpack gem >= 6.0.0, a possible XSS vulnerability exists when an application is running in development mode allowing an attacker to send or embed (in another page) a specially crafted URL which can allow the attacker to execute JavaScript in the context of the local application. This vulnerability is in the Actionable Exceptions middleware.

Breakdown
19.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 6 Jan 2021. No public exploit code or confirmed exploitation is recorded.

7 fixes in actionpack over 12 months. The latest fix listed for actionpack is 6.1.3.2.

Fixes in actionpackRubyGems package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 6.0.3.1CVE-2020-816419 Jun 2020
  2. 6.0.3.1CVE-2020-81662 Jul 2020
  3. 6.0.3.2CVE-2020-81852 Jul 2020
  4. 6.0.3.4CVE-2020-82646 Jan 2021
  5. 6.1.2.1CVE-2021-2288111 Feb 2021
  6. 6.1.3.2CVE-2021-2288527 May 2021
  7. 6.1.3.2CVE-2021-2290211 Jun 2021Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: actionpack.

RubyGemsactionpackGHSA-35mm-cc6r-8fjp

Upgrade to 6.0.3.5 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2021-22881).

Gemfilegem "actionpack", ">= 6.0.3.5"

First fixed in 6.0.3.4 for CVE-2020-8264.

Affected versions

If you runUpgrade to
6.0.0 up to 6.0.3.46.0.3.5first fix for this CVE: 6.0.3.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close