Patchfirst
CVE-2021-21628 EPSS 81.4%

Jenkins Build With Parameters Plugin 1.5 and earlier does not escape parameter names and descriptions, resulting in a…

Jenkins project · Jenkins Build With Parameters Plugin

Summary

The Jenkins Build With Parameters Plugin, version 1.5 and earlier, fails to escape parameter names and descriptions, leaving a stored cross-site scripting flaw in the plugin's build parameter handling. An attacker holding the Job/Configure permission can plant malicious script in those fields, which then executes in the browser of other users who view the affected job's parameters.

Official description · CVE.org

Jenkins Build With Parameters Plugin 1.5 and earlier does not escape parameter names and descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.

Breakdown
19.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 30 Mar 2021. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.jenkins-ci.plugins:build-with-parameters.

Mavenorg.jenkins-ci.plugins:build-with-parametersGHSA-xjrg-6fv9-6rjg

Upgrade to 1.5.1 or later

Set the version to 1.5.1 or later in your pom.xml or build.gradle.

The first fix for CVE-2021-21628. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 1.5.11.5.1

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close