Patchfirst
CVE-2021-21667 EPSS 75.7%

Jenkins Scriptler Plugin 3.2 and earlier does not escape parameter names shown in job configuration forms, resulting…

Jenkins project · Jenkins Scriptler Plugin

Summary

The Jenkins Scriptler Plugin (version 3.2 and earlier) fails to escape parameter names displayed in job configuration forms, creating a stored cross-site scripting flaw in the plugin's configuration interface. An attacker holding Scriptler/Configure permission can exploit this by storing malicious script in a parameter name, which then executes in the browser of any user who views the affected job configuration form.

Official description · CVE.org

Jenkins Scriptler Plugin 3.2 and earlier does not escape parameter names shown in job configuration forms, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Scriptler/Configure permission.

Breakdown
19.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 16 Jun 2021. No public exploit code or confirmed exploitation is recorded.

3 fixes in scriptler over 5 months. The latest fix listed for scriptler is 3.4.

Fixes in scriptlerMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 3.2CVE-2021-2166816 Jun 2021
  2. 3.3CVE-2021-2166716 Jun 2021
  3. 3.4CVE-2021-2170012 Nov 2021Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.jenkins-ci.plugins:scriptler.

Mavenorg.jenkins-ci.plugins:scriptlerGHSA-p479-rwhp-rwjx

Upgrade to 3.3 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2021-21668).

Set the version to 3.3 or later in your pom.xml or build.gradle.

The first fix for CVE-2021-21667.

Affected versions

If you runUpgrade to
All versions before 3.33.3

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close