Patchfirst
CVE-2021-22145 Public exploit EPSS 76.2%

A memory disclosure vulnerability was identified in Elasticsearch 7.10.0 to 7.13.3 error reporting

Elastic · Elasticsearch

Summary

A memory disclosure flaw exists in the error reporting of Elasticsearch, affecting versions 7.10.0 through 7.13.3. The vulnerable component is the code path that generates error messages returned to queries. An attacker who can submit arbitrary queries to Elasticsearch can send a malformed query that causes an error response containing fragments of a previously used data buffer, which may expose sensitive information such as documents or authentication details. The attack requires only the ability to submit queries to the service, with no user interaction specified.

Official description · CVE.org

A memory disclosure vulnerability was identified in Elasticsearch 7.10.0 to 7.13.3 error reporting. A user with the ability to submit arbitrary queries to Elasticsearch could submit a malformed query that would result in an error message returned containing previously used portions of a data buffer. This buffer could contain sensitive information such as Elasticsearch documents or authentication details.

Breakdown
25.6 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Metasploit) was available the same day.

  1. DisclosedPublic exploit codeMetasploitday 0

2 related vulnerabilities in the same code over 4 years.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2021-22145A memory disclosure vulnerability was identified in…21 Jul 2021
  2. relatedHigh

    Why these are linked:

    CVE-2025-49128Jackson-core Vulnerable to Memory Disclosure via Source Snippet…6 Jun 2025

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.elasticsearch.client:elasticsearch-rest-client.

Mavenorg.elasticsearch.client:elasticsearch-rest-clientGHSA-q394-h7f5-7f44

Upgrade to 7.13.4 or later

Set the version to 7.13.4 or later in your pom.xml or build.gradle.

The first fix for CVE-2021-22145. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
7.10.0 up to 7.13.47.13.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 1 community threat pulse (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

5 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close