Patchfirst
CVE-2021-29476 Critical · 9.8 EPSS 2.1%

Insecure Deserialization of untrusted data in rmccue/requests

WordPress · Requests

Official description · CVE.org

Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.

Breakdown
58.3 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 2 years after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+2 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: rmccue/requests.

Packagistrmccue/requestsGHSA-52qp-jpq7-6c54

Upgrade to 1.8.0 or later

Set the version to 1.8.0 or later in your composer.json.

The first fix for CVE-2021-29476. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
1.6.0 up to 1.8.01.8.0

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close