Patchfirst
CVE-2021-32610 EPSS 73.4%

In Archive_Tar before 1.4.14, symlinks can refer to targets outside of the extracted archive, a different vulnerability than CVE-2020-36193.

Summary

The flaw affects Archive_Tar, a PHP library for handling tar archives, in versions before 1.4.14, where symlinks inside an archive can point to targets outside the directory the archive is extracted into.

Heading is the official description · CVE.org
Breakdown
19.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 27 Jul 2021. No public exploit code or confirmed exploitation is recorded.

See the family tree

5 related vulnerabilities in the same code over 3 years.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2018-1000888PEAR Archive_Tar version 1.4.3 and earlier contains a CWE-502…27 Dec 2018
  2. relatedHigh

    Why these are linked:

    • Fixed one release later1.4.4 → 1.4.11 (pear/archive_tar)
    • Same code patched: Tar.php (machine-matched)Functions: _tarRecToSizecommit 59ace12commit 0670a05
    CVE-2020-28948Archive_Tar through 1.4.10 allows an unserialization attack…19 Nov 2020
  3. same family
    CVE-2020-28949PEAR Archive_Tar Deserialization of Untrusted Data19 Nov 2020KEV
  4. Next fix in the same packageHigh

    Why these are linked:

    CVE-2020-36193PEAR Archive_Tar Improper Link Resolution18 Jan 2021KEV
  5. relatedHigh

    Why these are linked:

    This CVECVE-2021-32610In Archive_Tar before 1.4.14, symlinks can refer to targets…27 Jul 2021

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 1 ecosystem. Main package: pear/archive_tar.

Packagistpear/archive_tarGHSA-p8q8-jfcv-g2h2

Upgrade to 1.4.14 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2020-28949, CVE-2020-36193).

Set the version to 1.4.14 or later in your composer.json.

The first fix for CVE-2021-32610.

Affected versions

If you runUpgrade to
All versions before 1.4.141.4.14

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (1)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • Packagistdrupal/core
    Affected: 9.2.0 up to 9.2.2; 9.1.0 up to 9.1.11; 8.0.0 up to 8.9.17Upgrade to 9.2.2 or later (older lines: 9.1.11, 8.9.17)

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

9 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close