Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system…
Apache Software Foundation · Apache Kylin
Apache Kylin's cube designer, in its configuration overwrite function, contains an OS command injection flaw in the handling of system parameter overrides. An attacker can break out of the quoted "--conf=" parameter value to inject arbitrary operating system commands, and the attack needs only network access with no authentication or user interaction.
Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.
- Exploited
- Not confirmed
- Reports
- 0
- Tactics
- 0/15
Exploitation timelineDated milestones for a CVE: when it was disclosed, when exploit code became public, when exploitation was confirmed, and when threat reports named it.
Disclosed on 13 Oct 2022. No public exploit code or confirmed exploitation is recorded.
Patch historyEarlier and later CVEs in the same code, in date order. It shows when a fix was bypassed or incomplete and which version finally fixed it.
5 fixes in kylin-server-base over 3 years. The latest fix listed for kylin-server-base is 4.0.3.
Fixes in kylin-server-baseMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.
- 3.0.1CVE-2020-193724 Feb 2020
- 3.1.0CVE-2020-1392514 Jul 2020
- 3.1.0CVE-2020-1392614 Jul 2020
- 4.0.2CVE-2022-2469713 Oct 2022
- 4.0.3CVE-2022-4462130 Dec 2022Latest listed
MITRE ATT&CKA public catalogue of the techniques attackers use, maintained by MITRE. Patchfirst uses it to describe what attackers do with a vulnerability. techniques
No techniques linkedNo ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.
Am I affected? What do I upgrade to?
From GitHub Security Advisories and OSV3 packages in 1 ecosystem. No single main package: each of these ships the affected code.
- Mavenorg.apache.kylin:kylin-core-commonAffected: All versions before 4.0.2Upgrade to 4.0.2 or later
- Mavenorg.apache.kylin:kylin-spark-projectAffected: All versions before 4.0.2Upgrade to 4.0.2 or later
- Mavenorg.apache.kylin:kylin-server-baseAffected: All versions before 4.0.2Upgrade to 4.0.2 or later