Patchfirst
CVE-2022-34777 EPSS 73.6%

Jenkins GitLab Plugin 1.5.34 and earlier does not escape multiple fields inserted into the description of…

Jenkins project · Jenkins GitLab Plugin

Official description · CVE.org

Jenkins GitLab Plugin 1.5.34 and earlier does not escape multiple fields inserted into the description of webhook-triggered builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Breakdown
19.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 30 Jun 2022. No public exploit code or confirmed exploitation is recorded.

6 fixes in gitlab-plugin over 6 years. The latest fix listed for gitlab-plugin is 1.9.7.

Fixes in gitlab-pluginMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.5.12CVE-2019-1030018 Apr 2019
  2. 1.5.12CVE-2019-1030118 Apr 2019
  3. 1.5.32CVE-2022-3095517 May 2022
  4. 1.5.35CVE-2022-3477730 Jun 2022
  5. 1.5.36CVE-2022-4341119 Oct 2022
  6. 1.9.7CVE-2025-2439722 Jan 2025Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.jenkins-ci.plugins:gitlab-plugin.

Mavenorg.jenkins-ci.plugins:gitlab-pluginGHSA-f655-xhvm-cwp4

Upgrade to 1.5.35 or later

Set the version to 1.5.35 or later in your pom.xml or build.gradle.

The first fix for CVE-2022-34777. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 1.5.351.5.35

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close