Patchfirst
CVE-2022-36094 High · 8.9 EPSS 64.8%

XWiki Platform Web Parent POM vulnerable to XSS in the attachment history

xwiki · xwiki-platform

Summary

A cross-site scripting flaw in the attachment history view of XWiki Platform's Web Parent POM (xwiki-platform) allows JavaScript stored in an attachment's name to execute for anyone who views that attachment's history. An attacker needs low-privileged authenticated access to upload an attachment with a script in its name, and exploitation requires a victim to view the attachment history.

Official description · CVE.org

XWiki Platform Web Parent POM contains Web resources for the XWiki platform, a generic wiki platform. Starting with version 1.0 and prior to versions 13.10.6 and 14.30-rc-1, it's possible to store JavaScript which will be executed by anyone viewing the history of an attachment containing javascript in its name. This issue has been patched in XWiki 13.10.6 and 14.3RC1. As a workaround, it is possible to replace `viewattachrev.vm`, the entry point for this attack, by a patched version from the patch without updating XWiki.

Breakdown
26.1 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 8 Sep 2022. No public exploit code or confirmed exploitation is recorded.

7 fixes in xwiki-platform-web over 15 months. The latest fix listed for xwiki-platform-web is 14.10.

Fixes in xwiki-platform-webMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 13.9CVE-2022-248208 Apr 2022
  2. 14.2CVE-2022-360918 Sep 2022
  3. 14.3-rc-1CVE-2022-360938 Sep 2022
  4. 14.3-rc-1CVE-2022-360948 Sep 2022
  5. 14.4.8CVE-2023-3446423 Jun 2023
  6. 14.9CVE-2023-2920715 Apr 2023
  7. 14.10CVE-2023-264732 Mar 2023Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-web.

Mavenorg.xwiki.platform:xwiki-platform-webGHSA-mxf2-4r22-5hq9

Upgrade to 13.10.6

Also affected, despite being newer: 14.0 up to 14.3-rc-1.

Set the version to 13.10.6 or later in your pom.xml or build.gradle.

The first fix for CVE-2022-36094. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
14.0 up to 14.3-rc-114.3-rc-1
1.0 up to 13.10.613.10.6

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close