GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code via…
GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code via java.lang.Runtime.getRuntime().exec in wps:LiteralData within a wps:Execute request, as exploited in the wild in June 2023. NOTE: the vendor states that they are unable to reproduce this in any version.
- Exploited
- Yes, in VulnCheck KEV
- Reports
- 0
- Tactics
- 0/15
Exploitation timelineDated milestones for a CVE: when it was disclosed, when exploit code became public, when exploitation was confirmed, and when threat reports named it.
First seen exploited the day it was disclosed.
Patch historyEarlier and later CVEs in the same code, in date order. It shows when a fix was bypassed or incomplete and which version finally fixed it.
5 fixes in gs-wms over 13 months. The latest fix listed for gs-wms is 2.25.2.
Fixes in gs-wmsMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.
- 2.20.4CVE-2023-3504212 Jun 2023
- 2.23.2CVE-2023-4133924 Oct 2023
- 2.24.1CVE-2024-2364220 Mar 2024
- 2.24.1CVE-2024-2381820 Mar 2024
- 2.25.2CVE-2024-364011 Jul 2024KEVLatest listed
MITRE ATT&CKA public catalogue of the techniques attackers use, maintained by MITRE. Patchfirst uses it to describe what attackers do with a vulnerability. techniques
No techniques linkedNo ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.
Am I affected? What do I upgrade to?
From GitHub Security Advisories and OSV3 packages in 1 ecosystem. No single main package: each of these ships the affected code.
- Mavenorg.geoserver:gs-wmsAffected: 2.20.0 up to 2.20.4; 2.19.0 up to 2.19.6; All versions before 2.18.6Upgrade to 2.25.6 or later (older lines: 2.19.6, 2.18.6)
- Mavenorg.geoserver:gs-wfsAffected: 2.20.0 up to 2.20.4; 2.19.0 up to 2.19.6; All versions before 2.18.6Upgrade to 2.25.7 or later (older lines: 2.19.6, 2.18.6)
- Mavenorg.geoserver:gs-wpsAffected: 2.20.0 up to 2.20.4; 2.19.0 up to 2.19.6; All versions before 2.18.6Upgrade to 2.20.4 or later (older lines: 2.19.6, 2.18.6)
What security researchers reported
Not named in any threat report yetAlso mentioned in 1 community threat pulse (AlienVault OTX)
Weaker evidencePulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.