Patchfirst
CVE-2023-37462 Public exploit Critical · 10.0 EPSS 91.6%

Improper Neutralization of Directives in Dynamically Evaluated Code ('Eval Injection') in…

xwiki · xwiki-platform

Summary

The flaw is an improper escaping issue in the document SkinsCode.XWikiSkinsSheet within the xwiki-platform product, which is XWiki's generic wiki platform. An attacker with low-privilege authenticated access over the network, and without any user interaction, can open a non-existing page whose name contains a crafted payload, escalating to programming rights that allow execution of script macros such as Groovy and Python for remote code execution with full read and write access to wiki contents.

Official description · CVE.org

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Improper escaping in the document `SkinsCode.XWikiSkinsSheet` leads to an injection vector from view right on that document to programming rights, or in other words, it is possible to execute arbitrary script macros including Groovy and Python macros that allow remote code execution including unrestricted read and write access to all wiki contents. The attack works by opening a non-existing page with a name crafted to contain a dangerous payload. It is possible to check if an existing installation is vulnerable. See the linked GHSA for instructions on testing an installation. This issue has been patched in XWiki 14.4.8, 14.10.4 and 15.0-rc-1. Users are advised to upgrade. The fix commit `d9c88ddc` can also be applied manually to the impacted document `SkinsCode.XWikiSkinsSheet` and users unable to upgrade are advised to manually patch their installations.

Breakdown
77.0 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 3 years after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+3 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-skin-ui.

Mavenorg.xwiki.platform:xwiki-platform-skin-uiGHSA-h4vp-69r8-gvjg

Upgrade to 14.10.4 or later

Set the version to 14.10.4 or later in your pom.xml or build.gradle.

The first fix for CVE-2023-37462. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
14.5 up to 14.10.414.10.4
7.0-rc-1 up to 14.4.814.4.8

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close