Patchfirst
CVE-2023-47248 Public exploit EPSS 14.5%

PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file

Apache Software Foundation · PyArrow

Official description · CVE.org

Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files). This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings. It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon. If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.

Breakdown
60.4 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 16 months after disclosure. Public exploit code (PoC-in-GitHub) appeared 2 years after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+16 mo
  3. Public exploit codePoC-in-GitHub+2 yrs

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: pyarrow.

Upgrade to 14.0.1 or later

pippip install "pyarrow>=14.0.1"

The first fix for CVE-2023-47248. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
0.14.0 up to 14.0.114.0.1

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 2 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

6 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close