Upgrade to 6.4.0 or later
Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2024-53677, CVE-2025-68493).
Set the version to 6.4.0 or later in your pom.xml or build.gradle.
First fixed in 6.3.0.2 for CVE-2023-50164.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 6.0.0 up to 6.3.0.2 | 6.4.0first fix for this CVE: 6.3.0.2 |
| 2.0.0 up to 2.5.33 Still affected on this line by CVE-2024-53677 (fixed in 6.4.0, a newer line); CVE-2025-68493 (no fix published). | 2.5.33 |
“Up to” means the second version is the fix and is not affected.