Patchfirst
CVE-2023-50290 Public exploit Medium · 6.5 EPSS 68.4%

Apache Solr: Host environment variables are published via the Metrics API

Apache Software Foundation · Apache Solr

Summary

Apache Solr versions from 9.0.0 before 9.3.0 expose host environment variables through the Metrics API, because the default hide-list only covers known secret Java system properties and cannot strictly control environment variables, which may be set host-wide. An attacker with network access to the Solr instance who holds the "metrics-read" permission (and therefore valid authentication, in Solr Clouds with authorization enabled) can read the unprotected environment variables, with no user interaction required.

Official description · CVE.org

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr. The Solr Metrics API publishes all unprotected environment variables available to each Apache Solr instance. Users are able to specify which environment variables to hide, however, the default list is designed to work for known secret Java system properties. Environment variables cannot be strictly defined in Solr, like Java system properties can be, and may be set for the entire host, unlike Java system properties which are set per-Java-proccess. The Solr Metrics API is protected by the "metrics-read" permission. Therefore, Solr Clouds with Authorization setup will only be vulnerable via users with the "metrics-read" permission. This issue affects Apache Solr: from 9.0.0 before 9.3.0. Users are recommended to upgrade to version 9.3.0 or later, in which environment variables are not published via the Metrics API.

Breakdown
29.4 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) appeared 22 months after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+22 mo

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.solr:solr-core.

Mavenorg.apache.solr:solr-coreGHSA-gg7w-pw2r-x2cq

Upgrade to 9.4.1

Fixes this CVE and 1 other known vulnerability in this package (CVE-2023-50386).

Still affected on this line by CVE-2026-44825 (no fix published).

Set the version to 9.4.1 or later in your pom.xml or build.gradle.

First fixed in 9.3.0 for CVE-2023-50290.

Affected versions

If you runUpgrade to
9.0.0 up to 9.3.09.4.1first fix for this CVE: 9.3.0

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close