Patchfirst
CVE-2024-20720 Critical · 9.1 EPSS 3.7%

Command injection in data collector backup due to insufficient patching of CVE-2023-38208

Adobe · Adobe Commerce

Official description · CVE.org

Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an attacker. Exploitation of this issue does not require user interaction.

Breakdown
61.4 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 49 days after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+49 days

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 1 ecosystem. No single main package: each of these ships the affected code.

  • Packagistmagento/community-edition
    Affected: 2.4.6-p1 up to 2.4.6-p4; 2.4.5-p1 up to 2.4.5-p6; 2.4.4-p1 up to 2.4.4-p7Upgrade to 2.4.6-p6 or later (older lines: 2.4.5-p8, 2.4.5)
  • Packagistmagento/project-community-edition
    Affected: 2.0.2 and earlierNo fixed version published

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

1 link, grouped by NVD tag
↑ ↓ chooseEnter openEsc close