Patchfirst
CVE-2024-4367 Public exploit Medium · 5.6 EPSS 70.7%

A type check was missing when handling fonts in PDF.js, which would allow arbitrary JavaScript execution in the PDF.js context. This vulnerability affects Firefox < 126, Firefox ESR < 115.11, and Thunderbird < 115.11.

Mozilla · Firefox

Summary

A missing type check when handling fonts in PDF.js, the PDF renderer bundled with Mozilla Firefox, allows arbitrary JavaScript to run in the PDF.js context. An attacker can exploit it over the network with no privileges or user interaction, though the attack is considered high complexity.

Heading is the official description · CVE.org
Breakdown
30.4 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) appeared 6 days after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+6 days

3 related vulnerabilities in the same code over 19 months.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2024-34342react-pdf's PDF.js vulnerable to arbitrary JavaScript execution…7 May 2024
  2. relatedHigh

    Why these are linked:

    This CVECVE-2024-4367A type check was missing when handling fonts in PDF.js, which…14 May 2024
  3. relatedLow

    Why these are linked:

    • Stated in the CVE textThis issue is related to CVE-2024-4367, but the root cause of this Nextcloud issue is that the product exposes executable example code on a same-origin basis.
    CVE-2025-59788Cross-site scripting (XSS) vulnerability in a reachable…4 Dec 2025

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: pdfjs-dist.

npmpdfjs-distGHSA-wgrm-67xf-hhpq

Upgrade to 4.2.67 or later

npmnpm install pdfjs-dist@4.2.67

The first fix for CVE-2024-4367. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 4.2.674.2.67

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

12 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close