Patchfirst
CVE-2024-52301 Public exploit High · 8.7 EPSS 44.8%

Laravel allows environment manipulation via query string

laravel · framework

Official description · CVE.org

Laravel is a web application framework. When the register_argc_argv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. The vulnerability fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, and 11.31.0. The framework now ignores argv values for environment detection on non-cli SAPIs.

Breakdown
66.5 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 7 months after disclosure. Public exploit code (PoC-in-GitHub) appeared 2 days after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+2 days
  3. First seen exploitedVulnCheck KEV evidence+7 mo

7 fixes in laravel/framework over 5 years. The latest fix listed for laravel/framework is 12.1.1.

Fixes in laravel/frameworkPackagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 7.24.0CVE-2020-249414 Sep 2020
  2. 8.22.1CVE-2021-2126319 Jan 2021
  3. 8.75.0CVE-2021-438087 Dec 2021
  4. 11.31.0CVE-2024-5230112 Nov 2024
  5. 11.36.0CVE-2024-1391810 Mar 2025
  6. 11.36.0CVE-2024-1391910 Mar 2025
  7. 12.1.1CVE-2025-275155 Mar 2025Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: laravel/framework.

Packagistlaravel/frameworkGHSA-gv7v-rgg6-548h

Upgrade to 11.31.0

Still affected on this line by CVE-2026-114509 (fixed in 12.68.0, a newer line).

Set the version to 11.31.0 or later in your composer.json.

The first fix for CVE-2024-52301.

Affected versions, by release line

If you runUpgrade to
11.0.0 up to 11.31.011.31.0
10.0.0 up to 10.48.23

Still affected on this line by CVE-2026-114509 (fixed in 12.68.0, a newer line).

10.48.23
9.0.0 up to 9.52.17

Still affected on this line by CVE-2026-114509 (fixed in 12.68.0, a newer line).

9.52.17
8.0.0 up to 8.83.28

Still affected on this line by CVE-2026-114509 (fixed in 12.68.0, a newer line).

8.83.28
7.0.0 up to 7.30.7

Still affected on this line by CVE-2026-114509 (fixed in 12.68.0, a newer line).

7.30.7
All versions before 6.20.45

Still affected on this line by CVE-2026-114509 (fixed in 12.68.0, a newer line).

6.20.45

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 1 community threat pulse (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close