Patchfirst
CVE-2024-6587 Public exploit High · 7.5 EPSS 34.4%

SSRF in berriai/litellm

berriai · berriai/litellm

Official description · CVE.org

A Server-Side Request Forgery (SSRF) vulnerability exists in berriai/litellm version 1.38.10. This vulnerability allows users to specify the `api_base` parameter when making requests to `POST /chat/completions`, causing the application to send the request to the domain specified by `api_base`. This request includes the OpenAI API key. A malicious user can set the `api_base` to their own domain and intercept the OpenAI API key, leading to unauthorized access and potential misuse of the API key.

Breakdown
64.9 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 22 days before it was disclosed.

  1. First seen exploitedVulnCheck KEV evidence22 days before
  2. Disclosedday 0

2 related vulnerabilities in the same code over 2 years. The latest fix listed for litellm is 1.56.2.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2024-6587SSRF in berriai/litellm13 Sep 2024
  2. relatedMedium

    Why these are linked:

    CVE-2026-114612LiteLLM is a proxy server (AI Gateway) to call LLM APIs in…22 Oct 2026

Fixes in litellmPyPI package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.40.0CVE-2024-52256 Jun 2024
  2. 1.40.15CVE-2024-571027 Jun 2024
  3. 1.40.16CVE-2024-575127 Jun 2024
  4. 1.44.8CVE-2024-658713 Sep 2024
  5. 1.44.12CVE-2024-960620 Mar 2025
  6. 1.53.1.dev1CVE-2024-1018820 Mar 2025
  7. 1.56.2CVE-2024-898420 Mar 2025Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: litellm.

Upgrade to 1.84.0 or later

Fixes this CVE and 6 other known vulnerabilities in this package (CVE-2026-35029, CVE-2026-40217, +4).

pippip install "litellm>=1.84.0"

First fixed in 1.44.8 for CVE-2024-6587.

Affected versions

If you runUpgrade to
All versions before 1.44.81.84.0first fix for this CVE: 1.44.8

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close