Upgrade to 6.4.2 or later
Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2025-31125, CVE-2026-39365).
npm install vite@6.4.2First fixed in 6.2.3 for CVE-2025-30208.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 6.2.0 up to 6.2.3 | 6.4.2first fix for this CVE: 6.2.3 |
| 6.1.0 up to 6.1.2 Still affected on this line by CVE-2026-39365 (fixed in 6.4.2, a newer line). | 6.1.3first fix for this CVE: 6.1.2 |
| 6.0.0 up to 6.0.12 Still affected on this line by CVE-2026-39365 (fixed in 6.4.2, a newer line). | 6.0.13first fix for this CVE: 6.0.12 |
| 5.0.0 up to 5.4.15 Still affected on this line by CVE-2026-39365 (fixed in 6.4.2, a newer line). | 5.4.16first fix for this CVE: 5.4.15 |
| All versions before 4.5.10 Still affected on this line by CVE-2026-39365 (fixed in 6.4.2, a newer line). | 4.5.11first fix for this CVE: 4.5.10 |
“Up to” means the second version is the fix and is not affected.