Patchfirst
CVE-2025-55184 Public exploit High · 7.5 EPSS 66.6%

A pre-authentication denial of service vulnerability exists in React Server Components versions 19.0.0, 19.0.1 19.1.0…

Meta · react-server-dom-webpack

Summary

A pre-authentication denial of service flaw exists in Meta's react-server-dom-webpack component of React Server Components (versions 19.0.0 through 19.2.1, including the related react-server-dom-parcel and react-server-dom-turbopack packages), where unsafe deserialization of HTTP request payloads sent to Server Function endpoints can trigger an infinite loop. An unauthenticated remote attacker with network access can send crafted requests that hang the server process and may stop it from serving subsequent HTTP requests, requiring no user interaction and no special configuration.

Official description · CVE.org

A pre-authentication denial of service vulnerability exists in React Server Components versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1, including the following packages: react-server-dom-parcel, react-server-dom-turbopack, and react-server-dom-webpack. The vulnerable code unsafely deserializes payloads from HTTP requests to Server Function endpoints, which can cause an infinite loop that hangs the server process and may prevent future HTTP requests from being served.

Breakdown
72.3 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 4 months after disclosure. Public exploit code (PoC-in-GitHub) appeared 1 day after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+1 day
  3. First seen exploitedVulnCheck KEV evidence+4 mo

A fix was bypassed or incomplete once on the same day. The latest fix listed for react-server-dom-webpack is 19.2.5.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2025-55184A pre-authentication denial of service vulnerability exists in…11 Dec 2025
  2. incomplete fixHigh

    Why these are linked:

    • Stated in the CVE textIt was found that the fix addressing CVE-2025-55184 in React Server Components was incomplete and does not prevent a denial of service attack in a specific case.
    • Linked in OSV/GitHub advisoryGHSA-7gmr-mq3h-m5h9
    • Fixed one release later19.0.2 → 19.0.3 (react-server-dom-webpack)
    • Fixed one release later19.0.2 → 19.0.3 (react-server-dom-turbopack)
    • Similar weakness in the same product (machine-matched)same package + description similarity
    CVE-2025-67779It was found that the fix addressing CVE-⁠2025-⁠55184 in React…11 Dec 2025

Fixes in react-server-dom-webpacknpm package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 19.2.1CVE-2025-551823 Dec 2025KEV
  2. 19.2.2CVE-2025-5518311 Dec 2025
  3. 19.2.2CVE-2025-5518411 Dec 2025
  4. 19.2.3CVE-2025-6777911 Dec 2025
  5. 19.2.4CVE-2026-2386426 Jan 2026
  6. 19.2.5CVE-2026-238698 Apr 2026Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

3 packages in 1 ecosystem. Main package: react-server-dom-webpack.

npmreact-server-dom-webpackGHSA-2m3v-v2m8-q956

Upgrade to 19.2.2 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2025-55182, CVE-2025-55183).

npmnpm install react-server-dom-webpack@19.2.2

The first fix for CVE-2025-55184.

Affected versions, by release line

If you runUpgrade to
19.2.0 up to 19.2.219.2.2
19.1.0 up to 19.1.319.1.3
19.0.0 up to 19.0.219.0.2

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (2)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • npmreact-server-dom-parcel
    Affected: 19.2.0 up to 19.2.2; 19.1.0 up to 19.1.3; 19.0.0 up to 19.0.2Upgrade to 19.2.2 or later (older lines: 19.1.3, 19.0.2)
  • npmreact-server-dom-turbopack
    Affected: 19.2.0 up to 19.2.2; 19.1.0 up to 19.1.3; 19.0.0 up to 19.0.2Upgrade to 19.2.2 or later (older lines: 19.1.3, 19.0.2)

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 8 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close