Patchfirst
CVE-2026-111497 KEVPublic exploit Critical · 9.8 EPSS 82.6%

Google Brotli Unchecked Return Value Vulnerability

Google · Brotli

Summary

The Brotli decoder in Google Brotli, specifically the file c/dec/decode.c, contains a buffer overflow flaw in versions 1.0.3 through 1.2.0 on all platforms. A remote, unauthenticated attacker can exploit it by sending a crafted Brotli-compressed stream, requiring no authentication, user interaction, or special configuration, to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code.

Official description · NVD

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Breakdown
79.8 / 100
Exploited
Yes, in CISA KEV
Reports
0
Tactics
4/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

First seen exploited 4 days after disclosure. Public exploit code (PoC-in-GitHub) was available 1 day before disclosure.

  1. Public exploit codePoC-in-GitHub1 day before
  2. Disclosedday 0
  3. First seen exploitedVulnCheck KEV evidence+4 days
  4. Added to CISA KEVEU database agrees+5 days

CISA KEV listing is when exploitation was confirmed, not necessarily the first attack.

See the family tree

2 related vulnerabilities in the same code over 17 months. The latest fix listed for brotli is 1.2.1.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2020-36846IO::Compress::Brotli versions prior to 0.007 for Perl have an…30 May 2025
  2. relatedMedium

    Why these are linked:

    This CVECVE-2026-111497Brotli Unchecked Return Value22 Oct 2026KEV

Fixes in brotliPyPI package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.0.8CVE-2020-3684630 May 2025
  2. 1.2.0CVE-2025-617631 Oct 2025
  3. 1.2.1CVE-2026-11149722 Oct 2026KEVLatest listed

techniques

4 , grouped by in kill-chain order, 4 cited passages 4

Initial AccessTA0001

Exploit Public-Facing Application T1190 Medium
AI mapping from the description · how it is exploited

remote unauthenticated input via crafted stream

allows a remote unauthenticated attacker to corrupt adjacent decoder state memory
From the official description (NVD) Original (opens in a new tab) ↗

ExecutionTA0002

Command and Scripting Interpreter T1059 Medium
AI mapping from the description · primary impact

arbitrary code execution from memory corruption

potentially execute arbitrary code
From the official description (NVD) Original (opens in a new tab) ↗

CollectionTA0009

Data from Local System T1005 Medium
AI mapping from the description · primary impact

memory disclosure enables data reading

disclose sensitive memory contents
From the official description (NVD) Original (opens in a new tab) ↗

ImpactTA0040

Application or System Exploitation T1499.004 Medium
AI mapping from the description · primary impact

decoder crash causes denial of service

cause a denial of service
From the official description (NVD) Original (opens in a new tab) ↗

Detection

0 rules for this CVE · 261 general rules for its techniques

Rules for this CVE

0 that reference CVE-2026-111497 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

General rules for this CVE’s techniques

These detect the technique in general, not this specific vulnerability.

Exploit Public-Facing ApplicationT1190149 general rules
Command and Scripting InterpreterT105995 general rules
Data from Local SystemT100514 general rules
Application or System ExploitationT1499.0043 general rules

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

2 packages in 1 ecosystem. Main package: brotli.

Upgrade to 1.2.1 or later

pippip install "brotli>=1.2.1"

The first fix for CVE-2026-111497. No other CVE tracked by Patchfirst affects this package.

Affected versions

If you runUpgrade to
All versions before 1.2.11.2.1

“Up to” means the second version is the fix and is not affected.

Other packages that bundle this code (1)

Forks, repackagings and products that include the affected code. Each has its own fixed version.

  • PyPIbrotlicffi
    Affected: All versions before 1.2.1.0Upgrade to 1.2.1.0 or later

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 23 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

21 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close