Patchfirst
CVE-2026-2652 Public exploit High · 8.6 EPSS 20.8%

Authentication Bypass in mlflow/mlflow

mlflow · mlflow/mlflow

Summary

The flaw is an authentication bypass in the mlflow/mlflow product, specifically in its FastAPI permission middleware, which only enforces authentication on /gateway/ routes when the server runs with --app-name basic-auth under uvicorn. An unauthenticated remote attacker with network access can reach unprotected routes such as the Job API and the OpenTelemetry trace ingestion API to submit, read, and cancel jobs and inject arbitrary trace data into experiments, without needing credentials or user interaction.

Official description · CVE.org

A vulnerability in mlflow/mlflow versions 3.9.0 and earlier allows unauthenticated access to certain FastAPI routes when the server is started with authentication enabled (`--app-name basic-auth`) and served via uvicorn (ASGI). The FastAPI permission middleware only enforces authentication on `/gateway/` routes, leaving other routes such as the Job API (`/ajax-api/3.0/jobs/*`) and the OpenTelemetry trace ingestion API (`/v1/traces`) unprotected. This allows unauthenticated remote attackers to submit jobs, read job results, cancel running jobs, and inject arbitrary trace data into experiments. The issue arises from an architectural mismatch between Flask and FastAPI authentication mechanisms, where the `_find_fastapi_validator()` function fails to handle non-`/gateway/` paths, resulting in a complete authentication bypass. This vulnerability is fixed in version 3.10.0.

Breakdown
77.6 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 3 months after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+3 mo

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: mlflow.

Upgrade to 3.17.0 or later

Fixes this CVE and 10 other known vulnerabilities in this package (CVE-2023-1177, CVE-2023-3765, +8).

pippip install "mlflow>=3.17.0"

First fixed in 3.11.0 for CVE-2026-2652.

Affected versions, by release line

If you runUpgrade to
All versions before 3.11.03.17.0first fix for this CVE: 3.11.0
All versions before 3.10.03.17.0first fix for this CVE: 3.10.0

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 7 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close