Patchfirst
CVE-2026-33453 Public exploit Critical · 10.0 EPSS 9.2%

Apache Camel: CoAP URI Query Parameter to Exchange Header Injection in camel-coap Allows Single-Packet Pre-Auth Remote…

Apache Software Foundation · Apache Camel

Summary

Apache Camel's camel-coap component fails to filter CoAP request URI query parameters, so they are copied directly into Camel Exchange In message headers. An unauthenticated remote attacker who can send a single CoAP UDP packet to a Camel route consuming from a coap:// endpoint can inject internal Camel headers, which can alter a header-sensitive downstream producer such as camel-exec and lead to arbitrary OS command execution, with the response returned to the attacker over CoAP.

Official description · CVE.org

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Apache Camel Camel-Coap component. Apache Camel's camel-coap component is vulnerable to Camel message header injection, leading to remote code execution when routes forward CoAP requests to header-sensitive producers (e.g. camel-exec) The camel-coap component maps incoming CoAP request URI query parameters directly into Camel Exchange In message headers without applying any HeaderFilterStrategy.   Specifically, CamelCoapResource.handleRequest() iterates over OptionSet.getUriQuery() and calls camelExchange.getIn().setHeader(...) for every query parameter. CoAPEndpoint extends DefaultEndpoint rather than DefaultHeaderFilterStrategyEndpoint, and CoAPComponent does not implement HeaderFilterStrategyComponent; the component contains no references to HeaderFilterStrategy at all. As a result, an unauthenticated attacker who can send a single CoAP UDP packet to a Camel route consuming from coap:// can inject arbitrary Camel internal headers (those prefixed with Camel*) into the Exchange. When the route delivers the message to a header-sensitive producer such as camel-exec, camel-sql, camel-bean, camel-file, or template components (camel-freemarker, camel-velocity), the injected headers can alter the producer's behavior. In the case of camel-exec, the CamelExecCommandExecutable and CamelExecCommandArgs headers override the executable and arguments configured on the endpoint, resulting in arbitrary OS command execution under the privileges of the Camel process. The producer's output is written back to the Exchange body and returned in the CoAP response payload by CamelCoapResource, giving the attacker an interactive RCE channel without any need for out-of-band exfiltration.                                                                                                                                                                         Exploitation prerequisites are minimal: a single unauthenticated UDP datagram to the CoAP port (default 5683). CoAP (RFC 7252) has no built-in authentication, and DTLS is optional and disabled by default. Because the protocol is UDP-based, HTTP-layer WAF/IDS controls do not apply. This issue affects Apache Camel: from 4.14.0 through 4.14.5, from 4.18.0 before 4.18.1, 4.19.0. Users are recommended to upgrade to version 4.18.1 or 4.19.0, fixing the issue.

Breakdown
78.3 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) was available the same day.

  1. DisclosedPublic exploit codePoC-in-GitHubday 0

2 fixes in camel-coap on the same day. The latest fix listed for camel-coap is 4.20.0.

Fixes in camel-coapMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 4.18.1CVE-2026-3345327 Apr 2026
  2. 4.20.0CVE-2026-4045327 Apr 2026Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.camel:camel-coap.

Mavenorg.apache.camel:camel-coapGHSA-695c-x5gc-94gj

Upgrade to 4.18.1 or later

Set the version to 4.18.1 or later in your pom.xml or build.gradle.

The first fix for CVE-2026-33453. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
4.18.0 up to 4.18.14.18.1
4.14.0 up to 4.14.64.14.6

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 9 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

6 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close