Patchfirst
CVE-2026-53435 Public exploit High · 8.8 EPSS 53.1%

In Jenkins 2.567 and earlier, LTS 2.555.2 and earlier, it is possible for attackers to have Jenkins deserialize…

Jenkins Project · Jenkins

Summary

A deserialization flaw in Jenkins core and its plugins (Jenkins 2.567 and earlier, LTS 2.555.2 and earlier) lets attackers have arbitrary types deserialized from a crafted config.xml submission. An attacker with low-privilege authenticated access, and no user interaction, can use this to impersonate other users and send requests on their behalf, potentially running Script Console code or reading arbitrary files from the Jenkins controller.

Official description · CVE.org

In Jenkins 2.567 and earlier, LTS 2.555.2 and earlier, it is possible for attackers to have Jenkins deserialize arbitrary types defined in Jenkins core or plugins from an attacker-controlled `config.xml` submission in a way that allows them to handle HTTP requests afterwards. This can be used to impersonate any user and send HTTP requests on their behalf, up to and including use of the Script Console to run arbitrary code, or to read arbitrary files from the Jenkins controller.

Breakdown
73.2 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 5 days after disclosure. Public exploit code (PoC-in-GitHub) appeared 2 days after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+2 days
  3. First seen exploitedVulnCheck KEV evidence+5 days

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.jenkins-ci.main:jenkins-core.

Mavenorg.jenkins-ci.main:jenkins-coreGHSA-g2xq-2v27-4rh3

Upgrade to 2.568 or later

Set the version to 2.568 or later in your pom.xml or build.gradle.

The first fix for CVE-2026-53435.

Affected versions, by release line

If you runUpgrade to
2.556 up to 2.5682.568
All versions before 2.555.32.555.3

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 9 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

15 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close