Patchfirst
CVE-2026-66066 Public exploit Critical · 9.5 EPSS 30.1%

Action Pack: Possible arbitrary file read and remote code execution in Active Storage variant processing

rails · rails

Summary

The flaw is in Active Storage's variant processing within the Rails framework (Action Pack), where libvips operations marked unsafe for untrusted content are not disabled. Applications are exposed when they use libvips and accept image uploads from untrusted users, and an unauthenticated remote attacker can craft an upload that invokes such an operation to read arbitrary files accessible to the Rails process, including environment variables and secrets.

Official description · CVE.org

Action Pack is a framework for handling and responding to web requests. In versions prior to 7.2.3.2, 8.0.5.1 and 8.1.3.1, Active Storage does not disable libvips operations marked unsafe for untrusted content, allowing a crafted upload to invoke such an operation. Consuming applications are affected when configured to use libvips and accept image uploads from untrusted users. An unauthenticated attacker may exploit this behavior to read arbitrary files accessible to the Rails process, including environment variables and application secrets. Exposure of credentials such as secret_key_base or external-service tokens may enable remote code execution or lateral movement. This issue has been fixed in versions 7.2.3.2, 8.0.5.1 and 8.1.3.1.

Breakdown
78.7 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 32 days after disclosure. Public exploit code (PoC-in-GitHub) was available 1 day before disclosure.

  1. Public exploit codePoC-in-GitHub1 day before
  2. Disclosedday 0
  3. First seen exploitedVulnCheck KEV evidence+32 days

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: activestorage.

RubyGemsactivestorageGHSA-xr9x-r78c-5hrm

Upgrade to 8.1.3.1 or later

Gemfilegem "activestorage", ">= 8.1.3.1"

The first fix for CVE-2026-66066. No other CVE tracked by Patchfirst affects this package.

Affected versions, by release line

If you runUpgrade to
8.1.0.beta1 up to 8.1.3.18.1.3.1
8.0.0.beta1 up to 8.0.5.18.0.5.1
All versions before 7.2.3.27.2.3.2

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

13 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close