Patchfirst
CVE-2012-0394 Public exploit EPSS 72.9%

The DebuggingInterceptor component in Apache Struts before 2.3.1.1, when developer mode is used, allows remote…

Summary

The DebuggingInterceptor component in Apache Struts, before version 2.3.1.1, contains a flaw that is reachable when developer mode is enabled. An attacker can execute arbitrary commands via unspecified vectors, and the conditions required (such as network access or authentication) are not specified.

Official description · CVE.org

The DebuggingInterceptor component in Apache Struts before 2.3.1.1, when developer mode is used, allows remote attackers to execute arbitrary commands via unspecified vectors. NOTE: the vendor characterizes this behavior as not "a security vulnerability itself.

Breakdown
24.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Exploit-DB) was available 2 days before disclosure.

  1. Public exploit codeExploit-DB2 days before
  2. Disclosedday 0

See the family tree

A fix was bypassed or incomplete 3 times over 4 years.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2012-0393The ParameterInterceptor component in Apache Struts before…8 Jan 2012
  2. same family
    This CVECVE-2012-0394The DebuggingInterceptor component in Apache Struts before…8 Jan 2012
  3. relatedMedium

    Why these are linked:

    CVE-2012-4387Struts 2.0.0 through 2.3.4 allows remote attackers to cause a…5 Sep 2012
  4. relatedMedium

    Why these are linked:

    CVE-2014-0094The ParametersInterceptor in Apache Struts before 2.3.16.2…10 Mar 2014
  5. incomplete fixHigh

    Why these are linked:

    • Stated in the CVE textNOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0094.
    • Similar weakness in the same product (machine-matched)same package + description similarity
    CVE-2014-0112ParametersInterceptor in Apache Struts before 2.3.20 does not…29 Apr 2014
  6. same family
    CVE-2014-0113CookieInterceptor in Apache Struts before 2.3.20, when a…29 Apr 2014
  7. incomplete fixHigh

    Why these are linked:

    • Stated in the CVE textNOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0113.
    • Similar weakness in the same product (machine-matched)same package + description similarity
    CVE-2014-0116CookieInterceptor in Apache Struts 2.x before 2.3.20, when a…8 May 2014
  8. same family
    CVE-2015-1831The default exclude patterns (excludeParams) in Apache Struts…16 Jul 2015

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.struts.xwork:xwork-core.

Mavenorg.apache.struts.xwork:xwork-coreGHSA-hmvj-gc9q-mg9p

Upgrade to 2.3.18

Fixes this CVE and 6 other known vulnerabilities in this package (CVE-2012-0391, CVE-2012-0392, +4).

Still affected on this line by CVE-2025-68493 (fixed in 6.1.1, a newer line).

Set the version to 2.3.18 or later in your pom.xml or build.gradle.

The first fix for CVE-2012-0394.

Affected versions

If you runUpgrade to
All versions before 2.3.182.3.18

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

7 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close