Patchfirst
CVE-2021-21341 Public exploit High · 7.5 EPSS 77.8%

XStream can cause a Denial of Service

x-stream · xstream

Summary

The XStream Java library (product: xstream, from vendor x-stream) contains a flaw in its XML deserialization handling that allows a crafted input stream to consume a large amount of CPU time, with the risk greater for systems that rely on its default blacklist rather than a whitelist limited to the required types. A remote attacker with no authentication, no required user interaction, and only network access to a service that deserializes untrusted input can exhaust CPU on the target and cause denial of service.

Official description · CVE.org

XStream is a Java library to serialize objects to XML and back again. In XStream before version 1.4.16, there is vulnerability which may allow a remote attacker to allocate 100% CPU time on the target system depending on CPU type or parallel execution of such a payload resulting in a denial of service only by manipulating the processed input stream. No user is affected who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.16.

Breakdown
30.2 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (PoC-in-GitHub) appeared 48 days after disclosure. No confirmed exploitation is recorded.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+48 days

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: com.thoughtworks.xstream:xstream.

Mavencom.thoughtworks.xstream:xstreamGHSA-2p3x-qw9c-25hh

Upgrade to 1.4.18 or later

Fixes this CVE and 12 other known vulnerabilities in this package (CVE-2013-7285, CVE-2019-10173, +10).

Set the version to 1.4.18 or later in your pom.xml or build.gradle.

First fixed in 1.4.16 for CVE-2021-21341.

Affected versions

If you runUpgrade to
All versions before 1.4.161.4.18first fix for this CVE: 1.4.16

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

15 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close