Upgrade to 1.4.18 or later
Fixes this CVE and 12 other known vulnerabilities in this package (CVE-2019-10173, CVE-2020-26217, +10).
Set the version to 1.4.18 or later in your pom.xml or build.gradle.
First fixed in 1.4.11 for CVE-2013-7285.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 1.4.10 up to 1.4.11 | 1.4.18first fix for this CVE: 1.4.11 |
| All versions before 1.4.7 Still affected on this line by CVE-2020-26217 (fixed in 1.4.14-java7, a newer line); CVE-2020-26258 (fixed in 1.4.15, a newer line); CVE-2020-26259 (fixed in 1.4.15, a newer line); CVE-2021-21341 (fixed in 1.4.16, a newer line); CVE-2021-21344 (fixed in 1.4.16, a newer line); CVE-2021-21345 (fixed in 1.4.16, a newer line); CVE-2021-21346 (fixed in 1.4.16, a newer line); CVE-2021-21351 (fixed in 1.4.16, a newer line); CVE-2021-29505 (fixed in 1.4.17, a newer line); CVE-2021-39144 (fixed in 1.4.18, a newer line); CVE-2021-39152 (fixed in 1.4.18, a newer line). | 1.4.7 |
“Up to” means the second version is the fix and is not affected.