Patchfirst
CVE-2021-21345 Public exploit Medium · 5.8 EPSS 72.3%

XStream is vulnerable to a Remote Command Execution attack

x-stream · xstream

Summary

XStream, a Java library for serializing objects to XML and back, contains a flaw in versions before 1.4.16 that allows deserialization-driven remote command execution on the host. An attacker with sufficient rights who can supply a crafted input stream over the network can trigger this, though it requires user interaction, a high-complexity condition, and does not affect deployments that use an explicit whitelist of minimal required types.

Official description · CVE.org

XStream is a Java library to serialize objects to XML and back again. In XStream before version 1.4.16, there is a vulnerability which may allow a remote attacker who has sufficient rights to execute commands of the host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.16.

Breakdown
28.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 22 Mar 2021. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: com.thoughtworks.xstream:xstream.

Mavencom.thoughtworks.xstream:xstreamGHSA-hwpc-8xqv-jvj4

Upgrade to 1.4.18 or later

Fixes this CVE and 12 other known vulnerabilities in this package (CVE-2013-7285, CVE-2019-10173, +10).

Set the version to 1.4.18 or later in your pom.xml or build.gradle.

First fixed in 1.4.16 for CVE-2021-21345.

Affected versions

If you runUpgrade to
All versions before 1.4.161.4.18first fix for this CVE: 1.4.16

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

16 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close