Upgrade to 2.4.5
Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2023-22249, CVE-2024-20720, +1).
Still affected on this line by CVE-2025-54236 (no fix published).
Set the version to 2.4.5 or later in your composer.json.
The first fix for CVE-2022-34258.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 2.4.4 up to 2.4.5 | 2.4.5 |
| 2.4.0 up to 2.4.3-p3 Still affected on this line by CVE-2024-34102 (fixed in 2.4.4-p9, a newer line); CVE-2025-54236 (no fix published). | 2.4.3-p3 |
| 2.3.0 up to 2.3.7-p4 Still affected on this line by CVE-2024-34102 (fixed in 2.4.4-p9, a newer line); CVE-2025-54236 (no fix published). | 2.3.7-p4 |
“Up to” means the second version is the fix and is not affected.