Patchfirst
CVE-2023-37941 Public exploit Medium · 6.6 EPSS 35.5%

Apache Superset: Metadata db write access can lead to remote code execution

Apache Software Foundation · Apache Superset

Official description · CVE.org

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

Breakdown
64.3 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 23 months after disclosure. Public exploit code (PoC-in-GitHub) was available 4 months before disclosure.

  1. Public exploit codePoC-in-GitHub4 mo before
  2. Disclosedday 0
  3. First seen exploitedVulnCheck KEV evidence+23 mo

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: apache-superset.

Upgrade to 2.1.1 or later

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2023-27524, CVE-2023-39265).

pippip install "apache-superset>=2.1.1"

The first fix for CVE-2023-37941.

Affected versions

If you runUpgrade to
1.5.0 up to 2.1.12.1.1

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close