Patchfirst
CVE-2023-39265 Public exploit Low · 3.8 EPSS 86.0%

Apache Superset: Possible Unauthorized Registration of SQLite Database Connections

Apache Software Foundation · Apache Superset

Summary

Apache Superset (Apache Software Foundation) fails to properly validate SQLite database connections, so connections can be incorrectly registered when alternative driver names such as sqlite+pysqlite are used or when databases are imported, which can cause unexpected file creation on Superset web servers. An attacker with high-privilege authenticated access, reachable over the network with low complexity and no user interaction, can exploit this, and the impact is more severe if Superset's metadata is stored in SQLite.

Official description · CVE.org

Apache Superset would allow for SQLite database connections to be incorrectly registered when an attacker uses alternative driver names like sqlite+pysqlite or by using database imports. This could allow for unexpected file creation on Superset webservers. Additionally, if Apache Superset is using a SQLite database for its metadata (not advised for production use) it could result in more severe vulnerabilities related to confidentiality and integrity. This vulnerability exists in Apache Superset versions up to and including 2.1.0.

Breakdown
62.6 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 23 months after disclosure. Public exploit code (Metasploit) was available the same day.

  1. DisclosedPublic exploit codeMetasploitday 0
  2. First seen exploitedVulnCheck KEV evidence+23 mo

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: apache-superset.

Upgrade to 2.1.1 or later

Fixes this CVE and 4 other known vulnerabilities in this package (CVE-2021-27907, CVE-2021-28125, +2).

pippip install "apache-superset>=2.1.1"

The first fix for CVE-2023-39265.

Affected versions, by release line

If you runUpgrade to
All versions before 2.1.12.1.1
2.1.0 and earlierNo fix published

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close